Skepticats Tracker
LnBlog
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
icon_project.png LnBlog / Closed Bug report #89 XSL sheet doesn't load - cross-domain request blocked
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
icon_info.png This issue has been closed with status "Fixed" and resolution "RESOLVED".
Issue basics
  • Type of issue
    Bug report
  • Category
    Not determined
  • Targetted for
    Version 2.0.0
  • Status
    Fixed
  • Progress
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
  • Estimated time
    Not estimated
  • Time spent
    No time spent
    Click here to see time logged against this issue
Issue details
  • Resolution
    RESOLVED
  • Reproducability
    Not determined
  • Severity
    Not determined
Attachments (0)
There is nothing attached to this issue
Duplicate issues (0)
This issue does not have any duplicates
Description

We need to set things up to not make cross-domain HTTP requests when the software is installed on a different domain than the blog. There are still some places where we do that and while it may have been OK ten years ago, we can no longer assume that's kosher.

Might want to look into either a symlinking mechanism or re-using that proxy script thing we already have.

Steps to reproduce this issue

Noticed this in an RSS feed, of all places. Go to http://linlog.skepticats.com/feeds/PowerShell_news.xml in Chrome and notice that nothing renders (which is slightly weird - not 100% sure if it's the same issue). Open up the network inspector and notice that the XSL sheet is blocked because it's a cross-domain request.

#2
 pageer (pageer)
Oct 26, 2017
Fixed the URLs to use the same kind of mechanism as scripts. Also turned off the default stylesheets since it turns out they don't actually work anyway.
Changes:
  • The issue was closed
  • Status changed: New => Fixed by pageer (pageer)
  • Percent complete changed: 0 => 100
  • Resolution changed: Not determined => RESOLVED