Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000010LnBlog[All Projects] Defectpublic2010-12-10 22:512010-12-30 00:53
Reporterpageer 
Assigned Topageer 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version0.9.0 
Target Version1.0.0Fixed in Version1.0.0 
Summary0000010: Wrapper scripts should not rely on include_path
DescriptionThe wrapper scripts for blogs rely on the include_path when there is no need. We already have to know the absolute path to the LnBlog install root and the blog root - there's no reason not so use it. It's clearer and better for security.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000026)
Source Control (developer)
2010-12-30 00:49

Changeset 82:686c6d3711ff by Peter Geer, Thu Dec 30 00:49:41 2010 -0500
Fix bug 0000019 and modified upgrade process to fix bug 0000010 and fix bug 0000011.
    lib/blog.php
    lib/blogentry.php
    lib/utils.php
    pages/config.php
    pages/showarchive.php
    plugins/sidebar_recent.php

- Issue History
Date Modified Username Field Change
2010-12-10 22:51 pageer New Issue
2010-12-10 22:51 pageer Status new => assigned
2010-12-10 22:51 pageer Assigned To => pageer
2010-12-30 00:49 Source Control Checkin
2010-12-30 00:49 Source Control Note Added: 0000026
2010-12-30 00:50 pageer Status assigned => resolved
2010-12-30 00:50 pageer Fixed in Version => 1.0.0
2010-12-30 00:53 pageer Resolution open => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker